2

I have just discovered that all Craft sites on our server no longer let users upload PNG files and I'm struggling to find the issue / fix.

The craft.log simply says 'Save operation failed' and the JS console mentions 500 internal server error.

I've tried various PNG formats, and weirdly other systems on our server using Imagemagick are running fine.

Anyone had a similar issue / suggestions for debugging?

2

If other image formats are working fine, then maybe check that you have Imagick installed and enabled on the server.

Eg.

sudo apt-get install imagemagick php5-imagick
sudo service apache2 reload

If you're on a shared host then either consult their knowledge base or contact support to check for Imagick availability.

Some servers/hosts only have the GD library installed by default, which isn't so good with PNG files.

| improve this answer | |
  • ImageMagick is installed and running, listed within Craft utils and phpinfo, and works fine within other CMS/Frameworks. Just rebooted server too without any change... – Tom Carwardine Aug 7 '15 at 9:54
  • Plus PNGs were being uploaded fine a couple of months ago, the only thing that's changed is the updates to Craft. – Tom Carwardine Aug 7 '15 at 9:56
  • 1
    Just tried commenting out the line as suggested here and it works craftcms.stackexchange.com/questions/6862/… – Tom Carwardine Aug 7 '15 at 10:05
  • I'm glad you got it sorted. – Rick Aug 7 '15 at 10:07
  • Hacking the vendor lib seems a bit extreme… I guess I'll ping support@ and see what they say. Thanks for your comments :) – Tom Carwardine Aug 7 '15 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.