2

I've followed Shanti's advice when something similar happened to her. However, it hasn't resolved my problem and I think something else is going on.

GoDaddy's support are quite usless (bascially just sales people). Having installed Craft as I normally would, I'm getting this Internal Server Error.

enter image description here

I can't even get to the point of installing craft; even if I try going to

www.domain.com/index.php?p=admin/install

I have a feeling it's something to do with how the directories are structured for people with multiple domains on a host/reseller account. It looks something like this: enter image description here

The website is setup to point to the "/website3/public" directory. I know I could put the Craft directory into the Public folder and fiddle with the index.php $craftPath variable. But I want to keep true to Crafts Installation guide, and keep those files secure.

So, if you have a similar setup; how might I go about trouble shooting the problem of getting things pointing in the right directions?

  • Not really an answer, so I'm placing it here. If you are getting that page my first reaction would be to remove the .htaccess. Then clear the storage runtime directory. Hope that helps. – Jason McCallister Jul 12 '15 at 2:04
  • I think Shanti's problem is completely different than yours. Your error isn't even making it to Craft (that's an Apache 500 Internal Server Error). If you have access to Apache's error logs maybe something useful is getting logged there? – Brad Bell Jul 12 '15 at 5:00
  • My list of sometimes useful things to try is here: craftcms.stackexchange.com/a/6634/130 – Marion Newlevant Jul 12 '15 at 6:53
3

Thanks for the advice guys. It's helped me rule out the directories being an issue (sort of). Turns out that I was able to access the files in the craft directory all along. My issue related to the database settings.

Typically, the 'server' setting in the 'craft/config/db.php' folder is set to 'localhost'. But for GoDaddy you need to use your hostname. Get that by following these instructions.

You will also need to amend your 'craft/config/general.php' settings to include:

'omitScriptNameInUrls' => false,

At this time, I am unable to get clean-urls working on my Craft install. When 'omitScriptNameInUrls' is set to true, and I try to access any page (besides the homepage), I get that Internal Server Error again. I may open an new question for this as it seems to be slightly unrelated now.

  • Solution for clean-urls found! Posted answer on Shantis' original question (see my first comment for link) – Mark Notton Jul 12 '15 at 13:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.