2

Getting this error in the PHP error log file while trying to install craft.

PHP Fatal error: Class 'Craft\DbCommand' not found

The file is there, permissions are granted and I've tried reinstalling twice. Any other ideas?

11
  • 1
    Sounds like a file is missing/corrupt. Can you try again with a fresh copy of Craft from buildwithcraft.com? – Brad Bell Jun 15 '15 at 20:17
  • Now I'm just getting a flash of a 500 error in the console on refresh, and then nothing. There's no log anymore either, since I completely reinstalled it. – strandall Jun 15 '15 at 20:52
  • You're following the installation instructions here? buildwithcraft.com/docs/installing – Brad Bell Jun 15 '15 at 22:21
  • I am, although I'm putting it in a subfolder since I don't want it to be the main site yet. I've done that before and haven't had any issues... – strandall Jun 16 '15 at 13:27
  • Now I got "PHP Fatal error: Class 'Craft\InfoModel' not found" in the php log a twice (but not every time I refresh so I don't think that's the issue anymore. I'm getting "Could not find your craft/ folder. Please ensure that $craftPath is set correctly in .../public/index.php" on the page now. I know the path is correct and the permissions are set to 774. – strandall Jun 16 '15 at 17:12
3

Even thought this is an old thread, I recently ran in to the same problem. It turned out to be a PHP version issue. I was running MAMP with PHP 7.0.0, once I switched that host to 5.6.10 it worked perfectly.

2
  • 1
    Craft is compatible with PHP 7 since 2.5 — are you running an older version? – Patrick Harrington May 26 '16 at 10:37
  • We have a site running Craft v2.3.2620 where I ran into this issue and where this solution worked in resolving it too. – Ben Parizek Nov 25 '16 at 23:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.