Take the 2-minute tour ×
Craft CMS Stack Exchange is a question and answer site for administrators, end users, developers and designers for Craft CMS. It's 100% free, no registration required.

We're setting up craft as a webservice. One of my programmers came to me and said every "slug" he called from the frontend application resulted in a 302 redirect to the login page of craft CP. Afer some investigation it seems that he didnt sent any Useragent string from his frontend curl client. After adding a useragent string everything went ok. Is this normal behaviour or can it be configured?

Thanks

share|improve this question

1 Answer 1

up vote 6 down vote accepted

This post may help: Is it possible to disable `requireUserAgentAndIpForSession` for specific instances?

Take a look at the requireUserAgentAndIpForSession config-setting.

Post from phone, sorry if formatting is a bit off.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.